Miranda IM

Results 1 to 8 of 8

Thread: File transfer issues in MSN

  1. #1

    File transfer issues in MSN

    Greetings,

    I have read a few threads before that have MSN file transfer issues, but most differ a bit from what I am experiencing.

    Basically everytime when I send a file I have so far been faced with three scenarios:

    1. A good send that proceeded with no hiccups.

    2. A slow send in which the file transfer speed will drop to low levels and start fluctuating. I am also unable to send the person I am sending file to a message (message box greyed out) or it would lag terribly if I was able to. Please note the other user has a 1.5mbps connection that is working fine.

    3. I cannot send a file at all. File transfer gets stuck at requesting, even when the other party has accepted.

    I understand that majority of the times people post their problems without showing their network logs. To help facilitate a solution to this problem which might in advertedly help everyone else, I am providing network logs for all three scenarios.

    Also, please be aware that I am using Miranda 0.4 with the newest MSN protocol.

    Good send:
    http://s8.yousendit.com/d.aspx?id=2J...W3LW18RDL5I0OX

    Slow send (Huge log):
    http://s8.yousendit.com/d.aspx?id=0Z...N1U3MLX3L0HDSN

    Cannot send:
    http://s8.yousendit.com/d.aspx?id=20...E16YBSNXGA6H73

    Appreciate any help!

  2. #2
    Join Date
    March 2005
    Location
    Moscow, Russia
    Posts
    583
    It's easy: your machine isn't accessible from the outside world. If you do a passive send (i.e. receiver hosts a transfer), all works Ok.

    An attempt to host the transfer yourself fails, cause another side can't connect with your computer, so the timeout error occurs and a transfer is being routed via the server, which is much slower. Probably you should tune your router for port mapping or a firewall to allow incoming connections on several ports, as described in the www.miranda-im.org -> Help -> KB -> How to transfer files article.

    The third case can be caused by the serious network lag, cause a connection between your machine and a hoster succeeded, but hoster hadn't provide you with an answer. Which client is on the other side?

  3. #3
    Thank you for your help!

    I've reconfigured my Miranda to use the same ports for MSN and ICQ; previously, I had specified different port ranges for the different protocols, not sure if that had caused the problem. Will test it out to see if it works better now.

    As for the third case, the client on the other side is MSN Messenger 6.2. My friend switched off Windows Firewall, so there's nothing blocking the connection from the other side. Would this issue be resolved too if I host the transfer myself?

  4. #4
    Greetings again.

    I am really really confused. Perhaps someone can give me advice?

    I have tried to reconfigure my MSN and router (Linksys WRT54G) and firewall (Outpost Pro 2.6).

    I have set the following options for my router:

    Port forwarding:

    24500-24505 for ICQ
    6891-6905 for MSN

    I have static IP enabled.


    These are the settings for Miranda:

    Connect to MSN via port 1863.

    Incoming and Outgoing Connections for MSN: 6901-6905, 6891-6900

    I have found that the ports I specify first will be the ones used to establish a connection to MSN's network. I had previously specified only one range, 6891 to 6900, which is actually by default only for file transfers in MSN, hence I was a bit uncomfortable when I found out via netstat that MSN was using these ports locally to link to their network instead of just P2P. Is there a better way to specify the ports for file sending and receiving? They all seemed lumped together.

    I had changed from using a universal set of ports for both MSN and ICQ because it didn't solve my problems, and I figured specifying a port range that differed from the default would complicate matters. Might be wrong.


    My firewall settings:

    Allow TCP outbound, Remote Port: 5190
    Allow UDP outbound, Remote Port: 5190
    Allow TCP outbound, Remote Port: 80-83, HTTPS, SOCKS, PROXY:3128, PROXY:8080, PROXY:8088, AOL_4
    Allow TCP outbound, LOCAL Port: 6901-6905
    Allow TCP outbound, LOCAL Port: 6891-6900
    Allow TCP inbound, Remote Port: 6891-6900

    Even with firewall disabled, when I try to send a file to my friend, it will result in a very laggy send. It will start off fine, but if we send each other messages the send will slow down and my MSN will most of the time crash. I am puzzled.

    I'm no expert in this, so I may be wrong, but when I did a netstat before and during the file transfer, no additional port was displayed. Does this mean that by using the same port to message and send file, I have congested the network?

    Really appreciate any help.

    Will post a log soon.
    Last edited by furyoo; 19 Apr 2005 at 5:09 AM.

  5. #5
    Hi here is the log.

    I sent a rather small file now so I'm not sure if you can tell anything from it. The short time period produced no noticeable lag, although I am unsure if that is due to the nature of the transfer.

    I sent the file to a friend I have always had the issue of laggy file transfer with. Again, no firewall on the other side. MSN 6.2.

    Here's the log:
    http://s11.yousendit.com/d.aspx?id=0...21J84UR1D2CYC3

  6. #6
    Join Date
    March 2005
    Location
    Moscow, Russia
    Posts
    583
    This log is Ok, you can look at it yourself. Here Miranda allocates a port for the direct transfer:
    [11:00:18 MSN] (1264) Port 6904 opened for incoming connections
    and waits for the incoming connection
    [11:00:18 MSN] p2p_fileActiveSendThread() started: listening
    but nothing happens and Miranda closes that port and begins to send data through server:
    [11:00:23 MSN] Incoming connection timed out, closing file transfer

    These results are expected, though :) cause, as you wrote, you didn't allow this port to listen:
    Allow TCP inbound, Remote Port: 6891-6900
    while you use port #6904.
    Last edited by ghazan; 19 Apr 2005 at 9:19 AM.

  7. #7
    Thank you very very much!!! I have it fixed and it's working well now.

    A point to note: The rule should be to allow TCP inbound from 6891 to 6905 for me, but I realised I should specify for local ports not remote.

    Thanks! =)

  8. #8

    Ass

    Quote Originally Posted by ghazan
    you should tune your router for port mapping or a firewall to allow incoming connections on several ports, as described in the www.miranda-im.org -> Help -> KB -> How to transfer files article.
    I AM AN ASS for not reading this earlier. :)

    it would be nice if the forums got reset every now and then, to get rid of old and useless messages (exactly like this message).

    request: Would it be possible to make "automatic xp firewall config plugin" to help new users on their way to using Miranda IM...?

Similar Threads

  1. File transfer using short file names.
    By Vicodin in forum Technical Support
    Replies: 7
    Last Post: 19 Aug 2007, 3:18 AM
  2. file transfer...(yes i know :P )
    By kanye in forum Technical Support
    Replies: 1
    Last Post: 8 Jan 2007, 12:07 AM
  3. work-around for 2 way file transfer, file sharing
    By imon9 in forum Feature Requests
    Replies: 11
    Last Post: 28 May 2006, 11:01 AM
  4. Replies: 3
    Last Post: 27 May 2005, 9:42 PM
  5. AIM file transfer
    By ayzianboy in forum Technical Support
    Replies: 1
    Last Post: 4 Apr 2005, 9:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •